New ERA R1041 Owner

Talk About Anything In Here Whether Its ERA Related Or Not Just Keep It Clean.
User avatar
Jezza
Posts: 168
Joined: Tue Oct 21, 2008 10:21 pm
Location: Stoneleigh, Warks

New ERA R1041 Owner

Post by Jezza » Fri Oct 24, 2008 12:53 pm

Hi I have just joined the ERA Forum (full name Jeremy Harris) and I have taken the plunge and purchased G543 TFK from AllMini's of Glossop. The car was previously owned by Fraser Scott from Brierley Hill and before that Joe Partridge from Wordsley.

Whilst I do have quite a lot of history with the car (including a bill for £2.5K engine and gearbox work from Derek's Mini's in Willenhall in Dec 2000) i am guessing that some of you guys will know the car and might be able to give me some details on its past? I do hope that i haven't bought a 'dog'.

As a self-confessed Mini Nut I have always wanted an ERA having worked my way up via a Mini 1000, 1275GT, MBE race-engined SPI Cooper and a JCG Works Mini 40. I hope to bump into some of you at future Mini events (I live in Coventry).

A couple of quick questions for now which you might know the answers to:

Can these cars usually run on either unleaded or super unleaded fuel - the handbook clearly states that leaded fuel should be used?

Does anyone know where a suitable exhaust for the ERA Turbo can be purchased (mine has already been welded twice to get it through MOT's so i guess it will not last much longer?
Attachments
ERA TURBO 001.JPG
ERA TURBO 001.JPG (139.21 KiB) Viewed 9846 times
ERA TURBO 001.JPG
ERA TURBO 001.JPG (139.21 KiB) Viewed 9846 times
Jeremy Harris

G543 TFK

R1041 BRG

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: New ERA R1041 Owner

Post by G96LUE » Fri Oct 24, 2008 9:15 pm

Hi Jeremy

Good to know it has gone to someone who realy wated an ERA.
i don't know much about the car except it looks in very good condition especially considering the high milage.

I assume the garage was honest about the milage. i know the listing on ebay was a little misleading and i had reported it to ebay.

i hope you will be using it to go to some shows.

i am trying to organse a large gathering of cars, hopefully 20, for the 50th show at longbridge next year. it would be good if you were able to be one of the 20.

i'm not sure about an exhaust. i used a metro turbo down pipe on mine, going into a stainless RC40 (single box).

I have attached a photo of from mitp 2007.
from left to right - Mine, Ricky's, yours now, & Richard's

hope to see you soon.

Darren
Attachments
me_ricky_fraser_richard1.jpg
me_ricky_fraser_richard1.jpg (39.97 KiB) Viewed 9835 times

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: New ERA R1041 Owner

Post by G96LUE » Fri Oct 24, 2008 9:23 pm

Hi Again.

Just to let you know the car is still listed for sale on ebay.

Regards

Darren

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: New ERA R1041 Owner

Post by G96LUE » Fri Oct 24, 2008 9:27 pm


User avatar
millermilla
Posts: 182
Joined: Mon May 07, 2007 10:16 pm
Location: Burgess Hill West Sussex

Re: New ERA R1041 Owner

Post by millermilla » Tue Oct 28, 2008 1:55 pm

I notice the car has been relisted on e-bay again. Is this car sold or did the sale fall through?
Keith Miller

User avatar
Jezza
Posts: 168
Joined: Tue Oct 21, 2008 10:21 pm
Location: Stoneleigh, Warks

Re: New ERA R1041 Owner

Post by Jezza » Tue Oct 28, 2008 8:12 pm

Car is definitely sold - I am picking it up on Saturday from AllMini's. I did notice that they have not taken it off eBay but I do know that the guy at AllMini's is on holiday this week.

Yes I would be interested in going to IMM which is just up the road from me in Longbridge (I live in Coventry).
Jeremy Harris

G543 TFK

R1041 BRG

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: New ERA R1041 Owner

Post by G96LUE » Tue Oct 28, 2008 8:38 pm

Excellent.

you are most welcome to a place on the stand.

i am not far away, only in walsall, so i might see you at some shows before then, maybe bingley hall ealy next year.

regards

Darren

paul
Posts: 276
Joined: Tue Jan 16, 2007 10:20 pm

Re: New ERA R1041 Owner

Post by paul » Fri Oct 31, 2008 10:16 pm

Hi Welcome to the list and ERA Ownership.

I am from Coventry also and own New Acre Cars on the Binley Road, I own the Black Japanese Spec one J666ERA which you might have saw at shows. If you ever need anything give me a shout we import lots of Minis and can get hold of most stuff at healthy trade prices.

I have two other ERA's both Green UK spec one needed a heavy restoration and one a UK spec which went to Japan and I brought it home.

The ERA exhaust has not been available for many years though occasionally through lots of pestering of former Rover dealers owners do turn up the odd one off a dusty shelf in the back of dealers premises.

Personally I would go for a Maniflow Full system for a turbo mini, they do it straight from Turbo back including downpipe.

I have one of these ready for my Black one which has a naff japanese slash cut centre exit exhaust at the moment.

Good luck with it.

Regards

Paul

User avatar
Jezza
Posts: 168
Joined: Tue Oct 21, 2008 10:21 pm
Location: Stoneleigh, Warks

Re: New ERA R1041 Owner

Post by Jezza » Sun Nov 02, 2008 10:19 pm

Thanks Paul - we met a few weeks ago when I popped down to New Acre with my 7 month old - just to let you know that the car seat does indeed fit in the back of an ERA!

Thanks for the tip on the exhaust - will wait for it to blow first before I change it.

I now have the car and made it back from Glossop in one piece though I have noticed that neither the Turbo Boost gauge nor the Oil Temperature gauge seem to be working - any Forum members in the Midlands who can recommend a 'local' specilaist who I could get these fixed up with?
Jeremy Harris

G543 TFK

R1041 BRG

paul
Posts: 276
Joined: Tue Jan 16, 2007 10:20 pm

Re: New ERA R1041 Owner

Post by paul » Mon Nov 03, 2008 1:03 am

Hi

Glad to know the seat fitted.

Oil temp wont really go up too much this time of year need a real enthusiastic drive to get that to go up in winter as it has a oil cooler which isnt thermostatically controlled.

Boost guage is more of a problem, is it shoing vacumn or boost at all? if not likley to be a broken joint or perished rubber connector. Suffered both before.

Pop it down I will have a look at it.

Paul

Post Reply