Glamis Castle Scotish Mini Show

Share Pictures Of Your ERA Mini Turbo's Here.
paul
Posts: 276
Joined: Tue Jan 16, 2007 10:20 pm

Glamis Castle Scotish Mini Show

Postby paul » Sat Jul 18, 2009 11:53 am

My ERA and a pic of it with some of the other cars we went up with looking moody under the shadow of Glamis Castle.
Attachments
groupcars2.jpg
groupcars2.jpg (127.99 KiB) Viewed 6638 times
paulsera1.jpg
paulsera1.jpg (152.46 KiB) Viewed 6638 times

User avatar
millermilla
Posts: 182
Joined: Mon May 07, 2007 10:16 pm
Location: Burgess Hill West Sussex
Contact:

Re: Glamis Castle Scotish Mini Show

Postby millermilla » Sat Jul 18, 2009 5:13 pm

That top photo is great, has it been played around with? It looks like a tilt shift photo
Keith Miller

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: Glamis Castle Scotish Mini Show

Postby G96LUE » Sat Jul 18, 2009 7:25 pm

fantastic pics Paul. :D

Did it run ok after the rolling road?

paul
Posts: 276
Joined: Tue Jan 16, 2007 10:20 pm

Re: Glamis Castle Scotish Mini Show

Postby paul » Sat Jul 18, 2009 8:17 pm

Pic of the pic being taken! We entititled this one praying to the mini gods!

Nothing fancy camera wise think it was actually on a mobile!

Paul

ERA has ran like a bag of s*** since it was on Rolling Road Darren, we had a few words on the Thursday, and its going back over. Boggs and misses and such between 2000 and 3000 they had gave it back to me with no oil in the dashpot and forgot to put the retaining ring on the dashpot. Was a pain in the bum driving it to Scotland with a couple of innos's as one had twin single choke dellortos so drank fuel over 55 and mine didnt like running under 60! On way back we went on our own and it pulled 170KMPH no bother, so top end is great like a scalded cat but horrible to drive.

How is yours with the new gasket on, oil issues still there?

Paul
Attachments
PIC_0610.jpg
PIC_0610.jpg (192.65 KiB) Viewed 6623 times

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: Glamis Castle Scotish Mini Show

Postby G96LUE » Sat Jul 18, 2009 9:00 pm

The new head gasket cured the overheating problem. I suspect it stemmed from when i replaced the rockers.

With regard to the running, mine sounds similar to yours.
it is ok on the flat at 40 in 4th (2000 revs) but will not accelerate from there in 4th. i have to drop it into 3rd, and get upto 60 before dropping it into 4th. From 3200 revs (in 2nd or 3rd) it accelerates nicely upto 6000 / 6500 revs.

i'm going to get it tuned again after ive fitted a new turbo and actuator later in the year.

i'm also after a new distrubutor as mine was over advancing so he blocked off my vacum pipe so it is static now.
if it was designed to advance i would rather it work correctly.

paul
Posts: 276
Joined: Tue Jan 16, 2007 10:20 pm

Re: Glamis Castle Scotish Mini Show

Postby paul » Sun Jul 19, 2009 12:16 am

Pretty much exactly the same as mine, It didnt do that before is pulled all the way I have ordered a carb service kit and will do this then take it back and I want to drive it on rolling road to know its right, is no good to me it going like a scalded cat and it wont go up a hill in 4th between 2000 and 3000...

Paul

User avatar
G96LUE
Posts: 466
Joined: Wed May 23, 2007 7:21 pm
Location: Walsall

Re: Glamis Castle Scotish Mini Show

Postby G96LUE » Thu Jul 30, 2009 12:57 pm

Hi Paul

It is traditional to give a gift to the organisers of the IMM.

How would you feel if we were to give a framed picture of your car taken in front of the castle (paulsera1.jpg).

If you are happy with this could you email me the photo and i will get an A4 printed, mounted and framed.

Regards

Darren

paul
Posts: 276
Joined: Tue Jan 16, 2007 10:20 pm

Re: Glamis Castle Scotish Mini Show

Postby paul » Thu Jul 30, 2009 2:40 pm

Hi would love it will see if there is a higher res copy as Mate took it.

Paul


Return to “Gallery”

Who is online

Users browsing this forum: No registered users and 1 guest